Forum Index

No notifications
Notifications

Favorites

No favorites found
Learn KnowledgeKube Course 1 Support Q&A on Course 1
KnowledgeKube Training > Learn KnowledgeKube Course 1 Support > Can't send e-mail View modes: 
User avatar
KnowledgeKube Staff
KnowledgeKube Staff
matt.pitman - 10/03/2016 09:35:46
   
RE:Can't send e-mail
olly19 wrote: Easy mistake to make I guess :D
Absolutely. Such a simple mistake, but at least it's easy to identify. Glad to hear you got it working, and congratulations on reaching the end of course 1!

User avatar
Advanced member
Advanced member
olly19 - 10/03/2016 09:32:55
   
RE:Can't send e-mail
That was it. I fixed the spelling and now an e-mail arrives after I click the button. Easy mistake to make I guess :D Thanks again for your help!

User avatar
KnowledgeKube Staff
KnowledgeKube Staff
matt.pitman - 10/03/2016 09:26:42
   
RE:Can't send e-mail
Am I right in thinking your e-mail template is named "New Account Confirmation - Oliver"? I ask because your expression is missing the "i" in "Confirmation", i.e. "New Account Confirmaton - Oliver " Try correcting the spelling in your expression, then try your expression again and let me know how you get on.

User avatar
Advanced member
Advanced member
olly19 - 10/03/2016 09:22:29
   
RE:Can't send e-mail
SendHTMLEmail("New Account Confirmaton - Oliver", "") Value =ERROR: SendHTMLEmail: The templateNew Account Confirmaton - Oliver is invalid

User avatar
KnowledgeKube Staff
KnowledgeKube Staff
matt.pitman - 10/03/2016 09:17:28
   
RE:Can't send e-mail
Would you mind copying the error details into this forum post? Be careful to remove your e-mail address from the text before you do it, mind! To copy the error, just right-click the trace item and select View Selected Trace Item. Then copy and paste the whole thing (minus your e-mail address) here.

User avatar
Advanced member
Advanced member
olly19 - 10/03/2016 09:14:43
   
RE:Can't send e-mail
Hi, yeah there's an error there. The template is invalid.. but I published it?

User avatar
KnowledgeKube Staff
KnowledgeKube Staff
matt.pitman - 10/03/2016 09:07:43
   
RE:Can't send e-mail
Hi again Olly! There are a number of things to check, but the most important one is the Form Trace. Open the Preview and fill out your New Accounts form, then proceed to your summary. Make sure the trace is running (the Start Form Trace button will be greyed out if so), then click your Send Email Confirmation button. Type the word ERROR into the trace window's Filter and press the Return key. Hopefully there won't be any entries there, but if there is one that lists your SendHTMLEmail expression in the Trace Details column, that will be your issue. Let me know how you get on :)

User avatar
Advanced member
Advanced member
olly19 - 10/03/2016 08:56:27
   
Can't send e-mail
Me again! Trying to send an e-mail (chapter 10) but nothing is coming through. Definitely clicked publish changes, but nothing's happening in the preview or on the page.

RSS Feed